Find the common error messages when exporting information to Xero and their solutions.
Error message |
The existing contact with name "[A]" cannot be updated to use new name "[B]". There is an existing contact with that name. |
When |
An invoice or RCTI failed to export from Expedo to Xero |
Cause |
The contact in Xero that matches the company in the invoice has been renamed in Xero, which caused the contact's ID in Xero to not match the one in Expedo anymore. |
Solution |
|
Error message |
Invalid company info. Please authenticate again. |
When | An Administrator-to-Agent invoice failed to export from Expedo to Xero |
Cause |
The user is authenticated to Xero under a company that is not the same as the company in Expedo One possible scenario is that with your user account in Xero you have access to multiple companies, and you have switched to another company. Another scenario is that you've recently changed your company name either in Expedo or in Xero and the name no longer matches. |
Solution |
either:
|
Error message | The contact with the specified contact details has been archived. The contact must be un-archived before creating new invoices or credit notes. |
When | An invoice failed to export from Expedo to Xero |
Cause |
The contact in Xero that corresponds to the host has been archived |
Solution |
either:
then, try exporting the invoice again. |
Error message | Invoice # must be unique |
When | An invoice failed to export from Expedo to Xero |
Cause |
There is another invoice in Xero whose number matches the invoice you are trying to export. Since the invoice number must be unique, Xero rejected your invoice. |
Solution |
either:
then, try exporting the invoice again. |
Error message | Invoice not of valid status for modification |
When | You have modified an invoice that has previously been exported to Xero and you now want to export the updates |
Cause |
The invoice has been archived, voided, or paid in Xero. Invoices in Xero in any of those statuses can no longer be modified. |
Solution | Void the invoice in Expedo and create a new one for export. |
Error message | Error: unauthorized_client : Unknown client or client not enabled |
When | An invoice failed to export from Expedo to Xero |
Cause | Your Expedo site has not been connected to Xero. |
Solution | At this stage, you need to request Expedo Support to help you with this connection. There is work in progress for you to be able to connect Expedo to your Xero account yourself which will be available in early 2023. |
Error message |
Xero API minute rate limit error calling GetContacts |
When | An invoice failed to export from Expedo to Xero |
Cause |
Expedo exceeded the maximum number of API calls per minute allowed by Xero. |
Solution | Try exporting the invoice again after 1 minute. |
Error message |
The TaxType code ‘OUTPUT' cannot be used with the account code '<code>’. |
When | An invoice failed to export from Expedo to Xero |
Cause |
The general ledger account used is of a type other than revenue/income in Xero. |
Solution | Change the account code to one that is for revenue/income. |
Error message | Unable to export to Xero / Export invoice button is missing / Export status column shows “NONE” |
When | Trying to manually export an invoice from Expedo to Xero |
Cause | Connection to Xero and integration preferences have not been set up correctly. |
Solution |
|